Tiếng Anh chuyên ngành:

http://www.englishclub.com/business-english/
Trau dồi tiếng anh chuyên ngành Thương mại

http://www.bbc.co.uk/business/

http://www.cambridge.org/
Các nguồn tài nguyên Tiếng anh chuyên ngành của trường đại học Cambridge. Bạn cần đăng ký

http://www.nonstopenglish.com
Các bài test tiếng anh thương mại, luật...., các levels khác nhau level 4 , level 3 , level 2 , level 1


Từ điển - Bách khoa thư:

http://www.vietdic.com/
Từ điển Anh - Việt, Oxford. Bộ từ điển tra cứu rất tiện và rõ ràng

Merriam-Webster Online
Bộ từ điển tiếng Anh có phát âm hàng đầu trên mạng

http://www.bartleby.com/61
Tra cứu bộ từ điển tiếng Anh The American Heritage Dictionary với phát âm

http://www.wikipedia.org
Bách khoa thư mở lớn nhất thế giới

http://www.bartleby.com/65
ColumbiaThe most up-to-date encyclopedia available contains over 50,000 articles, 40,000 bibliographic citations and 80,000 cross-references

Cambridge dictionaries Online
Từ điển Cambridge

http://www.oup.com
Từ điển Oxford Advanced Learner. Rất hay để bạn học mẫu câu
http://www.pdictionary.com
Từ điển giải thích bằng tranh

Enchantedlearning.com
Từ điển bằng tranh với âm thanh, minh hoạ và các liên kết

http://www.hyperdictionary.com
Siêu từ điển - tra mọi từ trong trang!!!

http://www.acronymfinder.com
Từ điển các từ viết tắt trong tiếng Anh

http://www.onelook.com
One Look: Hơn 900 bộ từ điển online cho phép bạn tra đồng thời cùng một lúc. Chẳng hạn, bạn có thể biết từ "monster" trong Encarta, trong từ điển Oxford, từ điển Britanica hồi đầu thế kỷ, định nghĩa, phát âm và những câu chuyện, nguồn gốc của từ...

Yourdictionary.com
Chào mừng bạn tới một trong những site về từ điển lớn nhất thế giới với hơn 1800 bộ từ điển các loại và 250 thứ tiếng!


Các bài luận tiếng Anh:

www.freeessay.com/
Các trang cung cấp các bài luận miễn phí theo chủ đề. Giờ thì bạn không còn sợ những kỳ thi vấn đáp tiếng Anh nữa chứ?


Ngữ pháp & Từ vựng Tiếng Anh

Edunet.com/english/grammar/
Văn phạm tiếng Anh

http://webster.commnet.edu
Trang rất rất phong phú về ngữ pháp tiếng Anh, được chia theo các đề mục cụ thể, chẳng hạn dưới đây là phần động từ:  http://webster.commnet.edu/grammar/verbs.htm

The Internet Grammar of English
Phân tích cấu trúc câu và mối quan hệ của các loại từ vựng....

http://www.grammarbook.com/
Trắc nghiệm ngữ pháp của bạn

Online Grammar TestBartlebyT
óm tắt cách dùng tiếng Anh

http://www.vocabulary.co.il/
Học từ vựng qua các trò chơi, rất thú vị

Funcornerhttp://a4esl.org/
Học từ vựng theo tuỳ theo trình độ của bạn, qua nhiều hoạt động và lĩnh vực khác nhau

http://www.rhlschool.com
Tập đọc tiếng Anh qua các bài tập theo chủ điểm, chẳng hạn các kỳ nghỉ, lễ hội, học về từ đồng nghĩa, trái nghĩa, danh, động và tính từ...

http://www.englishclub.com/business-english/
Trau dồi tiếng anh chuyên ngành Thương mại


Luyện nghe và phát âm:

Voanews.com/specialenglish/
Nghe Anh Mỹ theo các chủ đề ( đọc chậm và rất dễ nghe)
Cnn.com/audio/radio
- Hard Nghe Radio trực tuyến CNN

http://www.bbc.co.uk
- Hard Nghe Radio trực tuyến BBC ( Xem thêm )

Watch TV online
- Hard Xem những kênh truyền hình nổi tiếng như BBC, CNN, NBC...các kênh giải trí, thương mại, âm nhạc và rất nhiều thể loại khác nữa ( yêu cầu đường truyền tốt )

http://www.bbc.co.uk
Các bài dạy tiếng Anh trên BBC ( tiếng Việt ) , kèm theo dạy từ mới...

http://www.rocketboom.com/
Video Blog. Blog tin tức hàng ngày

http://www.manythings.org/listen/
Luyện nghe các bản tin của VOA, rất dễ theo dõi

http://www.voanews.com
Chương trình Anh ngữ sinh động của đài VOA, nghe bằngReal Player

http://www.odeo.com/listen
- Hard Nghe các radio khác nhau, cập nhật nhất, một kênh về IT khá nổi trên trang này:

This week in TechVr.com.vn
Nghe nói tiếng Anh trên mạng Internet - Listen to American English –

http://www.vr.com.vn/VRSpeak/index.htm
(Dành cho trình độ Beginer & Intermediate )

http://www.englishclub.com

Các bản tin luyện nghe hàng tuần

Petalia.org/stories
Trang đọc truyện online và luyện nghe qua các bài diễn văn nổi tiếng, truyện cổ tích... trên Petalia

http://repeatafterus.com/
Luyện nghe qua các câu chuyện cổ tích, thơ ca, viễn tưởng, các câu châm ngôn và các tác phẩm nổi tiếng ( recorders )

Những clips trên Google
Xem và nghe tin tức, những đoạn clip trên Google

Focusenglish.com
Trang này về các cuộc hội thoại hàng ngày. Bạn có thể vào rất nhiều chủ đề khác nhau ( ở đây là Romance )

Abcnews.go.com
- Hard Xem và nghe hai kênh nổi tiếng của ABC, Good
morning America vàWorld News TonightPodcasts.yahoo.com - Hard Nghe và đăng ký những trạm radio hay nhất trên Internet, theo lĩnh vực bạn quan tâm: nghệ thuật, chính trị, thể thao, âm nhạc, thương mại, khoa học......

Englishstudydirect.com
Các liên kết về các bài Test luyện nghe và luyện thi với miêu tả rất chi tiết
Esl.about.com/cs/listening/
Trang này cho bạn chọn 6 trình độ nghe với hàng tá liên kết cho bạn nữa!Great  Speeches
Hàng trăm bài diễn văn nổi tiếng thế kỷ 20, bạn có thể lắng nghe hàng chục chính trị gia hàng đầu thế giới phát biểu như Tony Blair, Bill Clinton , G. Bush, Nelson Mandela...

Poets.org
Academy of American Poets. Nghe hơn 50 nhà thơ đọc các tác phẩm của họ

Coudal.com
Nghe đọc các bài thơ hàng ngày, rất hay

Nbc.com/Video/
- Hard Xem và nghe những clip vui nhộn của đài NBC

Eleaston.com/
Các liên kết luyện nghe, phát âm, radio online theo nhiều kênh và chủ đề khác nhau

http://www.manythings.org/pp
Luyện phát âm

Englishclub.com
Các bài luyện phát âm cơ bản

Ship or sheepOupchina.com.hk
http://esl-lab.com/
Trang rất phong phú với nhiều bài tập luyện nghe cho bạn


Báo chí tiếng Anh:

Saigontimesweekly
Saigon Times Weekly: Trang web báo tiếng Anh với các mục như Vietnam Scene, Vietnam This Week, Press Highlights, Business, Tourism...

Vietnamnews.vnagency.com.vn
Báo Vietnam News, verson online

Inter.Herald Tribune
Diễn đàn Người đưa tin Quốc tế

Nypost.com
NewYork Post  (Mỹ)

Nytimes.com
New York Times  (Mỹ)

Theonion.comT
he Onion (Mỹ)

Washingtonpost.com
Washington Post  (Mỹ)

Guardian.co.uk
Guardian (Anh)

Telegraph.co.ukT
elegraph  (Anh)

Bangkokpost.net
Bangkok Post (Thái Lan)

Chinadaily.com.cn/
China Daily ( Trung Quốc )

Hinduonline.com
The Hindu  ( Ấn độ )

Jpost.com/
Jerusalem Post

Xem thêm: Chuyên trang báo chí tiếng Anh ( News )


Tests

Testing online
Rất nhiều bài Tests và liên kết các bài tests online ( Bạn có thể chọn các thể loại Quizz , poll , Question Bank hay Selected Online Tests

English-Test.net
Một trang tuyệt vời về các bài kiểm tra tiếng Anh với hàng trăm mức độ và thể loại. Bạn có thể thực hiện để chuẩn bị cho bất kỳ cuộc thi nào của bạn TOEFL, IELTS, GMAT, TOEIC...

http://www.testden.com/
Các bài thi TOEFL trực tuyến...Bạn cần đăng ký.

http://www.1-language.com
Bài thi TOEIC trực tuyến

TOEFL exam
Test of English as Foreign Language: Hoàn thành Các bài Test Tiếng Anh này là tiêu chuẩn để bạn vào bất cứ Trường đại học nổi tiếng nào trên thế giới

IELTS exam
International English Language Test System: Chương trình kiểm tra tiếng Anh, hãy xem bạn có đủ tiêu chuẩn để đi du học chưa?

http://www.testmagic.com/
Nhiều bài test và tips cho các kỳ thi tiếng Anh khác nhau, TOEFL, IELTS, GRE, SAT, GMAT...

Gre.org/codelst.html
Download tài liệu luyện thi GRE

ESL Blue's Diagnostic Test
Very useful - gives you quizzes for your mistakes. For Beginner & immediate level

English Placement Test
Bạn muốn thi xếp chỗ để biết trình độ mình nên học? Vậy tham gia thử kỳ thi xếp chỗ này xem sao nhé!

http://www.world-english.org/test.htm Written Comprehension Test
Kiểm tra trình độ đọc hiểu tiếng Anh của bạn

Churchill House Assessment Exams
  *           Elementary
  *           Intermediate
  *           Upper-Intermediate
  *           Advanced
http://www.edict.com.hk
Bài luyện nghe chuẩn bị cho kỳ thi IELTS

http://ead.univ-angers.fr
...và cho TOEFL

Englishclub.com
Hướng dẫn, các tips cho các kỳ thi tiếng Anh, TOEFL, TOEIC, các bài test level....

Peak's Online Interactive Englis


Các trang liên kết - Một số trang khác:

Một số trang khác:

TOEFL Prep links
Rất nhiều liên kết hay về kỳ thi TOEFL như Barron's TEFL Prep Center, TESTWISE, Peter Chadwick's TOEFL Practice, English-Zone...

Ohio University's CALL
Trang học tiếng Anh rất phong phú với nhiều mục như luyện kỹ năng Grammar, Reading, Writing, Listening, Speaking, Vocabulary, học theo các chủ đề : World News, Society & Politics, History & Culture, Science & Technology... với rất nhiều liên kết tại ESL Links

Rong-chang
Rất nhiều liên kết học tiếng Anh cho bạn về Listening, Reading, Writing, Grammar, Vocabulary, Pronunciation, Quizzes, Games..liên kết theo chủ đề.

English at Home
Học ngữ pháp, luyện nghe tiếng Anh qua các trò chơi...

Englishrules.com
Ghé vào "phần văn vẻ" của site để đọc các tác phẩm văn học trên net. Rất nhiều liên kết: Project Bartleby, Internet Classics Archive, Jack London...

Các
trang Tiếng Việt:

mã:

Anh (English Club)
CLB tiếng Anh trên TTVNOL, nơi bạn có thể trao đổi và học hỏi rất nhiều điều về tiếng Anh: các cách để cải thiện kỹ năng nghe, nói đọc và viết, tham gia dịch các mẩu truyện, trao đổi về ngữ pháp, từ vựng và phương pháp học tiếng Anh của bạn. Mục lục các topic

Free-english.com
Các Trò chơi ESL: Văn phạm, luyện đọc, chính tả, từ vựng. Khá thú vị!

CLB Tiếng Anh VNN
Học tiếng Anh qua trang ngữ pháp, trang truyện đọc và tham gia diễn đàn thảo luận

Học tiếng Anh (Vietanhedu)
Rất nhiều bài Test ở các trình độ khác nhau, kinh nghiệm luyện thi, kinh nghiệm phỏng vấn việc và phần ôn luyện ngữ pháp tiếng Anh. Nếu bạn không chắc về ngữ pháp tiếng anh thì xem lại ở đây nhé

Petalia.org/stories
Trang đọc truyện online trên Petalia

Hp-vietnam.com
Trang tóm tắt ngữ pháp tiếng anh, test trực tuyến, một số bài học tiếng anh trực tuyến

Dethi.com
Luyện thi TOEFL, học tiếng Anh trên net

Bbc.co.uk
Trang học tiếng Anh bằng tiếng Việt của BBC với rất nhiều bài nghe theo chủ đề, tin tức, ngữ pháp, từ vựng, các bài quiz và test online

Elearning.com.vn/
Trường học Anh ngữ trực tuyến.Free English Test

Cleverlearn.com/VN
Một số trò chơi và bài trắc nghiệm trực tuyến cho bạn

Diendan.vietnamnet.vn
Các diễn đàn Học và trao đổi tiếng Anh

Goldenkey.edu.vn

http://www.iievn.org
Institute of International Education

Trên Forum Petalia
Trao đổi và thảo luận về học tiếng Anh với các mems Petalia

Vietdic.com
Từ điển Anh - Việt, Oxford. Bộ từ điển tra cứu rất tiện và rõ ràng

Làng Toàn Cầu British Council

Trang Web của Hội Đồng Anh với mục đích là tạo ra một sân chơi cho mọi thành viên của BC từ hơn 100 nước trên thế giới nói chuyện, trao đổi học tập. Một trang rất hay để học tiếng Anh qua các bài kiểm tra trực tuyến, các câu chuyện, jokes, bài hát...
English Department -Stanford
English Department: Các chương trình dạy và học tiếng Anh, cách viết luận, nghiên cứu ngôn ngữ...

English test
Học tiếng Anh trực tuyến qua phần Học từ vựng chuyên ngành, các bài test ngữ pháp nhỏ, phòng luyện đọc và phòng nghe...

Học tiếng Anh
Rất nhiều bài Test ở các trình độ khác nhau, kinh nghiệm luyện thi, kinh nghiệm phỏng vấn việc và phần ôn luyện ngữ pháp tiếng Anh. Nếu bạn không chắc về ngữ pháp tiếng anh thì xem lại ở đây nhé

CLB Tiếng Anh VNN
Học tiếng Anh qua trang ngữ pháp, trang truyện đọc và tham gia diễn đàn thảo luận

Bbc.co.uk/vietnamese/learningenglish
Trang học tiếng Anh bằng tiếng Việt của BBC với rất nhiều bài nghe theo chủ đề, tin tức, ngữ pháp, từ vựng, các bài quiz và test online

Usingenglish.com/
Trang học tiếng Anh rất phong phú với các nội dung như:
Test Yourself, Grammar Glossary, Language Resources,
Article Archive với rất nhiều liên kết hay

Manythings.org
Rất rất nhiều thứ để bạn học online, dưới đây chẳng hạn

www.englishtips.org
bạn phải đăng kí rồi mới tải tài liệu .

www.englishforvietnamese.com

www.e4vn.com

www.duhoc.com